Pioneer Finance - Issue with bank statement connection – Incident details

Issue with bank statement connection

Resolved
Major outage
Started about 1 month agoLasted about 3 hours

Affected

Pioneer Hub

Updates
  • Resolved
    Resolved

    This incident has been resolved. We're monitoring for futher issues

  • Identified
    Identified

    Some bank statements are failing to connect to our system. We are investigating the issue.