Scheduled for March 12, 2024 at 9:00 PM – 9:10 PM
Affects
Online Portal
Under maintenance from 9:00 PM to 9:10 PM
Completed
March 12, 2024 at 9:10 PMCompleted
March 12, 2024 at 9:10 PMMaintenance has completed successfully
In progress
March 12, 2024 at 9:00 PMIn progress
March 12, 2024 at 9:00 PMMaintenance is now in progress
Planned
March 12, 2024 at 9:00 PMPlanned
March 12, 2024 at 9:00 PMThere is a small upgrade to our database over the next 15 minutes. Please be patient.