Incoming calls are not reaching us

Resolved
Major outage
Started 12 days ago Lasted 1 day

Affected

Phone System
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    This issue continues to affect our services. If you need to contact us urgently, please do so through our contact form. We'll be in touch.

  • Identified
    Identified

    We aren't receiving calls at this moment. We are continuing to work on a fix for this incident.